Urgent Maintenance
Resolved
May 1, 2026 at 4:34pm UTC
Maintenance complete, we apologise for the major delay and lack of communication. Our team has been overwhelmingly busy working to get everything back online. Existing customers, please check your email for a credit refund voucher.
Affected services
Updated
May 1, 2026 at 4:34pm UTC
Maintenance ended
Affected services
Created
Apr 26, 2026 at 10:00pm UTC
We are going to be carrying out some critical fixes and updates that need to be fixed as soon as possible due to security reasons. This downtime will happen 11pm BST, we currently do not have an ETA on when servers will be running again. We are sorry for any inconvenience.
Affected services